Symptom
Even though the relevant permissions have been corrected configured for a Dynamic Group, users are still unable to edit fields in the Candidate Profile for certain candidates.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to Recruiting
- Go to Candidates' candidate profile
- See that the fields are not editable
Cause
There are, currently, two possible causes for this issue:
- The candidate doesn't have any country associated to their candidate profile.
- The candidate is from a country that is not one of countries permissioned in the list for the dynamic group in the field-permissions configured in the Candidate Profile.
Resolution
It's possible to give permissions to users to edit the candidate profile of candidates. That happens using Dynamic Groups and associating a country that the groups have permission to edit.
So, for the Cause 1, the solution would be to assign a country to the candidate. That can be done through Odata API or SFAPI, or you can ask the candidate to manually change it in their candidate profile.
As for the Cause 2, in field-permissions section of the Candidate Profile Template, the list of the countries that are permissioned to those dynamic groups doesn't have the country of the candidate in question. So, if you would like to that candidate to be edited you can: ask them to manually change it in their candidate profile, or change it through Odata API or SFAPI.
Keywords
candidate profile, not able to edit, edit, candidate, profile, can't edit, not permission, don't have permission, no permission, permission, rights, editable, not editable, can't modify. , KBA , LOD-SF-RCM , Recruiting Management , Problem