Symptom
- Employee did not go through I9 process
- No I-9 document has populated for the candidate
- In Superadmin, candidate is showing the wrong DivCountry value
Environment
SAP SuccessFactors Onboarding 1.0
Cause
Incorrect corporate structure mapping, as a result the wrong DivCountry value is displayed for the candidate.
Resolution
For Customers
- Open a support ticket
- Subject: KBA 2824583 - Onboarded in the US didn't go through I9 panels - Onboarding 1.0
- Component: LOD-SF-OBD-I9
Problem Description:
|
For Implementation Partners, Consultants, or Support:
- Go to SuperAdmin (Onboarding backend)
- Check what value is displayed under 'DivCountry' key for the candidate.
- Then, check which Corporate Structure Level is used in Form I-9 Company Level.
- Get the 'Data Key for Level Code' and search it in the candidate's HRData record.
- Copy the value and check what country is displayed for the corresponding level in Onboarding > Reference Files > Corporate Structure.
- If the Country is configured other than UNITED STATES OF AMERICA (e.g. UNITED KINGDOM), then this must be changed to UNITED STATES OF AMERICA since I9 only applies for the US.
Keywords
ONB 1.0, OBD, corporate structure, DivCountry, repeated, wrong, key, I9, US I9, I9 Panels, DivCode , KBA , LOD-SF-OBD-I9 , I9 Issues and requests for Onboarding , LOD-SF-OBD , Onboarding , Problem
Product
SAP SuccessFactors Onboarding all versions