Symptom
You would like to add multiple ID values as ABC EFG XYZ in the Ticket ID field available in the Advanced Search of the Tickets view of the Service work center, but notice that the field does not accept the multiple values. (ABC EFG XYZ refer to ticket ID's in the system)
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Service work center.
- Navigate to Tickets work center view.
- Open the Advanced Search pane.
- Copy the values ABC EFG XYZ and add them in the field.
- Click on Search.
- Notice that even though the ID values exist in the system, the search does not return any results using multiple values.
Cause
The system does not display any results since there are no separators being used between the ID values, which is unexpected for the system logic and therefore it is not able to tell when an ID stops and the other starts.
Resolution
The Ticket ID field available in the Advanced Search only accepts multiple values if these are separated using a semicolon like ABC; EFG; XYZ;
Once the separators are added, the search will return the values accordingly.
Keywords
Tickets; Service; Advanced Search; Multiple Values; Multiple Entries; Filter; Filtering; Ticket ID; ID; Cloud for Customer; C4C; , KBA , LOD-CRM-SRP , Service Request Processing , How To