Symptom
The field "Location name" from Outlook is not available / doesn't get synced to C4C.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Create an Outlook visit via C4C Add In, which has a field called Location.
- Enter location = ABC (ABC represents your entered location).
- Sync the visit from Outlook to C4C.
- In the C4C UI: Go to the Visit work centre.
- Go to the Visit view and open the Visit 1234 (1234 represents the visit Id of the freshly synched visit).
- Value ABC is nowhere visible on the Visit.
The field does not have a direct link to the Visit UI.
The fields 'Location name' and 'Additional Location name' are available in MDRS, in the XML and in Data work bench.
Cause
We store 'location_name' and 'Additional_location_name' in the backend, but as of now the field 'Location' is not available within C4C in Visit UI.
The field 'Location' in outlook does not get synced to C4C.
The fields 'location_name' and 'Additional_location_name' refer to the address of the customer account and they are set according to the logic for visit addresses.
When you have a sync from Outlook from a Meeting to a Visit, then the Location.Meeting field does NOT get synced to location name in Visit.
Even if a Customer/Prospect is assigned to this Visit it takes the location from the Visit and NOT the Address from the Customer.
=> The visit is assigned to the address of the customer.
Resolution
The visit address will be taken from the Customer.
Keywords
KBA , LOD-CRM-ACT-VST , Visit Planning , LOD-CRM-GW-OUT , Outlook , Problem