SAP Knowledge Base Article - Public

2826167 - Extension Field Of Data Type Web Address and E-mail Address Are Not Available For Defining Workflow Rule

Symptom

Extension fields of data type Web Address and E-Mail Address are not available in "Define Conditions" while creating a Workflow Rule.

Environment

 SAP Cloud for Customer

Reproducing the Issue

Prerequisite: Two Extension Fields of Type "Web Address" and "E-mail Address" are created in Opportunity header view, which are to be used while creating Workflow rule.

RUI extn field.jpg

  1. Go to the Administrator Work Center.
  2. Select the view Workflow Rules.
  3. Click on New to create a new Workflow.
  4. Select the Business Object as Opportunity.
  5. Click on Next and go to the Define Conditions view.
  6. Click on Add Group.
  7. Look on to options available in Dropdown list in "Field", on Edit Condition Screen.
  8. Newly created extension field of Type "Web address" and E-mail address" are not available in drop down list.

Cause

Field Data of type "Web Address" and "E-mail Address" are not supported in workflow.

Resolution

  • Extension field is of data Type "Web Address" and "E-mail Address" is not supported while defining workflow rules, due to which this field is not available while Creating workflow.
  • This is the expected behavior for the Workflow Scenario.
  • If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

Extension Field, URL, Web address, E-mail Address, Workflow rule, Opportunity Header, drop down, Add group, Not available , KBA , web address, field, not, workflow rule , e-mail address, workflow rule, not , LOD-CRM-OPP , Opportunity Management , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer core applications 1908