Symptom
You have created an extension field in the ECC Sales Orders screen, but you see that there are no services for extending the same to other business object
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to ECC Sales Orders workcenter
- Create an extension field ABC (where ABC is the name of the extension field)
- Select Start Adapatatoin
- Find for the field ABC
- Select Edit
- Go to Services facet
Here you will see that you cannot add the extension field to a web service
Cause
ECC sales orders technically doesn't exist as a business object in cloud for customer system and hence extension scenarios via services are not possible.
This is the reason system doesnt show any services.
Resolution
As per the current system behavior, you will not be able to extend the fields to created in ECC sales order Screen and this work center only supports an online search in the ERP system for sales orders using search criteria such as sales order ID, purchase order ID, account ID and product ID.This online search in ERP system fetches the list of orders that match the specified criteria.
Alternatively , you can implement a BADI(Business Addin) and then extended all the standard and custom fields in that business add in and then extend it to your services.
Keywords
Uitlities, ECC Sales Order, Extension field, business object, Services , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-IND-UTL , Utilities , Problem