Symptom
In your Intercompany Scenario, you notice that there is a Process Communication Error in the Sales/Service Order. Upon further inspection, the error is related to an unexpected Currency Conversion that has not been maintained.
Environment
SAP Business ByDesign
Reproducing the Issue
In a Sales Order scenario:
- Go to the Sales Orders work center.
- Open the Sales Orders view.
- Select and Open Sales Order ABC (ABC represents the Sales Order ID involved in the Intercompany Scenario).
- Click on View All.
- Navigate to the Document Flow tab.
- Click the red icon representing the Process Communication Error.
- You see error Sales Order ABC cannot create a Purchase Request.
In a Service Order scenario:
- Go to the Service Orders work center.
- Open the Service Order Processing view.
- Select and Open Service Order ABC (ABC represents the Service Order ID involved in the Intercompany Scenario).
- Click on View All.
- Navigate to the Document Flow tab.
- Click the red icon representing the Process Communication Error.
- You see error Service Order ABC cannot create a Purchase Request.
Then, following these steps:
- Go to the Application and User Management work center.
- Open the Process Communication Errors view.
- Change the Filter to Open Errors with Incidents.
- Select the Process Communication Error for document ABC (ABC represents your Sales/Service Order ID).
You can see that the error is "Exchange rate XXX / YYY on ZZ/ZZ/ZZZZ missing for currency conversion" (XXX/YYY represents the currency and ZZ/ZZ/ZZZZ represents the date).
However, you don't expect this currency conversion to be necessary for this scenario.
Cause
This happens because the fulfillment for the Sales/Service Order is External, so when the Purchase Request is created, the Seller (Of the Purchase Request) becomes the Supplier (From the Sales/Service Order), and the Buyer (Of the Purchase Request) becomes the Account (From the Sales/Service Order).
The default currency for the Supplier is XXX and that of Buyer is YYY, so the system requires the currency conversion to be maintained for tax calculations.
Resolution
To prevent this issue in future cases, you will need to maintain the requested currency conversion. This can be done by following these steps:
- Go to the General Ledger work center.
- Click on the Edit Exchange Rates common task.
- Click on Add Row.
- Maintain the relevant information.
If this is already happening to a document, after performing these steps:
- If the currency for the item can still be changed you can solve the issue via a dummy change for the currency by changing the currency to any currency (Do not hit enter) and add the original currency again and now hit enter.
- Otherwise you will need to raise an incident to SAP detailing the Sales/Service Order ID so we can make this scenario consistent from a Backend perspective.
See Also
1961446 - Error Message : Exchange rate Country/Currency on DD.MM.YYYY missing for currency conversion
Keywords
Intercompany ; Sales Order ; Service Order ; Purchase Request ; Currency Conversion , KBA , SRD-CRM-ORD , Orders & Contracts , How To