Symptom
When adding a pay target to an employee, the pay component base salary amount and/or frequency get erased and turn to a negative percentage value
Environment
Employee Central - Pay Component
Employee Central - Business Rule
Compensation Information - Pay Target
Reproducing the Issue
- Go to any employee profile
- Go to actions - compensation (or simply edit the compensation portlet)
- Scroll down to Pay target
- Add any Pay Target
- Notice that the amount and frequency get erased and the amount displays negative percentage value
Cause
This behavior is dictated by a business rule configured in the system:
a propagation rule like (migratedRule__xxxx)
This rule is set to trigger onChange from "Pay Component".
To verify and confirm this behavior, disable all the migrated rules on this field and add them back one by one to find the one causing the behavior.
Resolution
As such this would be an expected behavior based on current system configuration
If you do not want this behavior disable the indicated rule
NOTE:
These migrated rules are among those that were converted from xml to business in 1902 release.
This behaviour would be particularly prevalent with instances built on the backbone of Model Companies.
See Also
2769253 - Propagation XML Migration - New Rule Behaviors & Known Issues
2751468 - 1902: Propagation XML Migration to Business Rules FAQ
Keywords
Migrated rule, Pay Component, Pay Component Recurring, Pay Target, Percentage, Stricken out, , KBA , LOD-SF-EC-CMP , Compensation Information & One-Time Bonus , LOD-SF-CMP , Compensation Management , Problem