SAP Knowledge Base Article - Public

2829740 - "readyToHire" Field did not Update to "Yes" After New Employee Step due to Database Query Time-out [Integration with BizX] - Onboarding 1.0

Symptom

  • Ready to Hire field in OnboardingCandidateInfo object fails to change value to Yes after completing New Employee Step
  • The following error message is shown in the server level: "Connection Timeout Expired. The timeout period elapsed during the post-login phase. The connection could have timed out while waiting for server to complete the login process and respond; Or it could have timed out while attempting to create multiple active connections. The duration spent while attempting to connect to this server. The wait operation timed out"

Environment

SAP SuccessFactors Onboarding 1.0 - All Versions

Reproducing the Issue

The Onboarding activity is moved to Orientation Step and in Admin Center under Manage Data, the OnboardingCandidateInfo object fails to update the readyToHire flag.

Note

There is no error in audit trail to show that it fails to update

Cause

This kind of behavior is due to a database query timed out and was not able to insert a record. This can be due to unexpected high load on the database server.

Resolution

For Live Customer(s)

System Administrators have 2 options. First is to manually update via Import and Export (See KBA 2419074) or Second, contact SAP Product Support to resend the integration message to BizX from Onboarding. If you choose the latter, please see below on how to contact SAP Product Support team.

 

Contact SAP SuccessFactors Cloud Product Support

Please reach out to SAP SuccessFactors Cloud Product Support in SAP One Support Launchpad via SAP Expert Chat or Support case. In addition, follow the template when creating an case and provide the needed information below.

  • Subject: KBA 2829740 - Resend Onboarding Integration Message
  • Component: LOD-SF-OBD-INT

Problem Description:

  1. BizX Company ID 
    • [Insert affected instance]
  1. Affected Hire/Candidate
    • [Insert affected hire/candidate's name]
    • [Insert screenshot of the issue]
  1. Permission to resend the Onboarding Integration Message
    • [Insert approval]
  1. Username for Support Access (Read the agreement below)
    • [Insert Username]
  • May we have your approval for accessing your system environment to continue request? (Reply with your confirmation and username to access, refer to KBA listed below)
  • With your approval, accessing your system environment you agree for the actions we will take below.
    1. Review the data of affected users and compare it to those users who are working as expected.
    2. Capture screenshots/record screen clips of the issue.
    3. Analyze your system configuration
  • To know how to grant support access to SAP Cloud Product Support, please read the full article on 'How to Grant Support Access to SuccessFactors Support Staff' by clicking the reference KBA 2088892.

Keywords

Connection Timeout Expired, period elapsed, post-login phase, waiting, server, complete the login process, respond, attempting, multiple active connections, duration spent, wait operation timed out , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , Problem

Product

SAP SuccessFactors Onboarding all versions