SAP Knowledge Base Article - Public

2829856 - Custom Job Offer Detail Token in Offer Letter is Not Getting Resolved - Recruiting Management

Symptom

Custom Job Offer Detail Token in Offer Letter is not getting populated while sending to candidate email.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. After the Offer Detail step, create an Offer Letter
  2. Select the Offer Letter template
  3. Click in Preview button and notice the custom job offer detail token is not getting resolved

Cause

If you had created a custom token of a custom field in the Offer Detail Template, which field information is coming from the Job Application Template or Job Requisition Template, the token will not populate, if this field has not been made as "Reportable". In the way the system is designed, only custom fields that are made as "Reportable" will resolve the value into an Offer Detail token, since only "Reportable" custom fields can be edited in the Offer Approval step.

Same label is assigned to different field ID in different templates. For example: Field label "Basic Salary" is configured in offer template 1 in field ID "basic". The label is also used in offer template 2 for field ID "customlong1". The token might be reference to other field instead of the one you are expecting.

Resolution

To resolve the value into the Offer Detail token, you must make the field reportable in Provisioning. Please, refer to the KBA 2081508 on how to make a custom field reportable. In case you would not like to make the field reportable, you must use a token to pull the field value from the previous source, like Job Application Template or the Job Requisition Template.

Please also ensure that if the field on the Offer Detail template is derived from either Job Requisition or Job Application Template, that this field is definitely configured on the Job Requisition or Job Application also in the first place. To validate the offer detail templates against other templates, you can go to Provisioning>Import/Update/Export Offer Detail Template and click on "Validate Against Other Templates" to check any discrepancies between the offer detail template and other templates.

Also if the fields are updated in the application the offer approval process should be retriggered for the value to be updated in the Offer Letter.

Note: Custom operatorTeam tokens are not supported. Make sure field label is consistent in all offer templates to avoid confusion on which field is reference to.

Note: Enum fields which are referenced from the application are not editable in the offer and should not be used as custom tokens on the offer and should not be made reportable in provisioning under offer detail, instead the field can be used as a token from the application (eg. token must come from its original source).

See Also

2823512 - How are Standard and Custom fields permissioned as read or write in the Offer Detail template

2081508 - Custom Reportable Recruiting Fields - Recruiting Management

Keywords

resolving, Issue, Missing, information, Custom, token, not, working, JOB_OFFER_DETAIL_CUSTOM, enum, token, rcm, recruiting, , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem

Product

SAP SuccessFactors Recruiting all versions