Symptom
You could not find the field while creating work flow rule
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Application user management work center
- Go to work flow rules view
- Click on new button
- In the second step click on add group
- In the drop down you did not find desired field
Cause
Only selected fields are currently added in the Workflow rule. You need to create extension field and map the value.
Resolution
For example: You wanted to create a workflow rule that send an email when an order has been Acknowledged.
Follow below steps to create extension field:
- Go to purchase request and order work center
- Go to Purchase orders view
- Choose all Purchase orders
- Decide whether you want to use column "Status" value(Acknowledgement Received) or the column" PO acknowledgement status" value(Acknowledged)
- Then using adaptation mode create one extension field,
- In the pop up screen where you enter details of Extension field you have one check box "Calculated", check mark it.
- You can see new field "Calculation rule" choose either Status (Status/PurchaseOrderLifeCycleStatusCode) or PO Acknowledgment Status (Status/PurchaseOrderConfirmationStatusCode) as per the decision made earlier and save it
- Later click on save button in the adaptation screen and then publish the changes on adaptation screen.
Then
- Go to Application user management work center
- Go to work flow rules view
- Click on new button
- In the second step click on add group
- In the drop down you can see the extension field
Note: Ensure that extension field is appearing in the document for which you are creating work flow rule.
Keywords
extension field not appearing , KBA , SRD-CC-BTM , Business Task Management , AP-SIP , Supplier Invoice Processing , AP-POP-PO , Purchase Order , Problem