SAP Knowledge Base Article - Public

2830534 - Invoice Date is Missing When Creating from Occurrence Time Frame in Contract or Sales Order

Symptom

In the contract, you have maintained Invoice Scheduling reccurenace to create invoice schedule date for each month. After apply the recurrence to the line, some invoice dates are not created by system.

For example, contact ABC, line10.  (ABC represents the ID of the contract)

Price per Period option is ticked for the line, it is started from 21/06/2017 and ended on 20/06/2020. (duration=3 years)

In the Invoice Schedule, the invoice date 01/07/2017 and 01/08/2017 are missing.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Go to the Contracts view.
  3. Edit one contract ABC and go to Items tab. 
  4. Select line10, Price per Period is ticked. The item is started from 21/06/2017 and ended on 20/06/2020. (duration=3 years)
  5. Go to the Invoice Schedule sub tab under Pricing and Invoicing tab, click Edit Invoicing Time Frame, the Recurrency is maintained to have inovice on the first day of every month from 21/06/2017 to 20/06/2020.

You expect that system creates 36 invoice schedule dates from 01/07/2017 to 01/06/2020. In fact, system creats 34 invoice schedule dates started from 01/09/2017. The first 2 dates for June and July in 2017 are missing. 

Cause

For monthly recurrence pattern, the start date is always limited to before 2 years from current date.

In this exmple, current date is 23/08/2019. When creating recurrence invoice date, the start date determined is 23/08/2017. Therefore system created the first schedule invoice date to 01/09/2017. The other dates in the past would have to be added manually.

Resolution

This is currenty the system design.

Keywords

KBA , AP-RC-ISC , Invoice Schedule , Problem

Product

SAP Business ByDesign all versions