SAP Knowledge Base Article - Public

2830551 - User not available in LMS after SF User Connector run

Symptom

User Connector - SF run with status "completed" on Provisioning Employee Export job, but with status on LMS is: WARN - Some records were rejected, showing some exceptions. (Message: Code: 1161 Message: Entity invalid.)

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. SF User Connector run
  2. Employee Export job completed successfully on Provisioning
  3. On Learning: Go to System Admin > Connectors > User Connector - SF > View Results

View Results.png

  1. Serial Number with the completion status: WARN - Some records were rejected
  2. Check the Messages and Exceptions and details on connector report

View Details.png

  1. Verify the Connector Run Details to see what is the Entity affected

Connector Run Details.png

  1. On System Admin > Connectors > User Connector - SF > Show archived input files

archive input files.png

  1. Check the affected entities data previously mentioned,for this case, the EMAIL column
  2. Find out that the file has an invalid value for column "EMAIL" (containing a phone number, for example)

Cause

In this case, user record on Learning was not created by SF User Connector because the system rejected the value of e-mail column based on e-mail validation rules.

Resolution

  1. Check the e-mail value filled in on affected user's records
  2. Change the e-mail to a valid value
  3. Wait for the next scheduled date of SF User Connector to run, or run the job manually
  4. Check if the user records were accepted and created on Learning

When implementing the solution the expected behavior is that the user record will be created and the user will have access to LMS, as the connector will run without exceptions.

NOTE: Since connectors can be used to import thousands of records in the system, we highly recommend that you engage with our Professional Services organization or an implementation partner before attempting to utilize a connector to import/update data, especially in a production environment.

Keywords

records rejected, user not created, entity invalid, code 1161, sf user connector , KBA , LOD-SF-LMS-CON , Connectors , Problem

Product

SAP SuccessFactors Learning all versions