SAP Knowledge Base Article - Public

2830695 - Newly Created Brand is not Available in Career Site Builder

Symptom

After creating a new brand in Career Site Builder, it is not available for use under the Pages or Appearance sections

Environment

SAP SuccessFactors Recruiting Marketing

Reproducing the Issue

  1. Create a new brand in Career Site Builder > Tools > Brand Management
  2. Go to Appearance > Styles (for instance)
  3. Notice the new brand is not available.

Cause

There can be two reasons for this:

  • The Brand Management section needs to be refreshed as described in KB article 2735286.
  • The newly created brand is identical to an existing brand.

Resolution

The resolution for each scenario are:

  • Press the Save button in Tools > Brand Management
  • Generally, this happens when trying to use capitalization to distinguish between two brands - for instance TEST and test. The URL identifier in CSB does not take into account capitalization, and therefore the second brand will be ignored (not displayed) as it is identical to the first one.
  • It is necessary to distinguish brands using different names as capitalization is irrelevant. This is an expected behaviour.

Guidelines for Brand creation:
The recommended characters to use are : letters in lower case (a-z) , letters in uppercase (A-Z) , numbers (0-9) hyphen (-) and underscore (_)

WARNING:
Most special characters will not work
Spaces are not supported
Also note that as a best practice, using ALL CAPS should be avoided as consecutive capital letters could interfere with category and job delivery rules by triggering unwanted operators such as "AND" "OR" "NOT".

See Also

KB article 2735286 - Brands not showing when creating Email Layout in Recruiting Marketing

Keywords

sf, success factors, CSB, RMK, brand management , KBA , LOD-SF-RMK-CSB , Career Site Builder , Problem

Product

SAP SuccessFactors Recruiting all versions