SAP Knowledge Base Article - Public

2831417 - Service Order or Sales Order Cannot be Completed as Delivery Status is Not Started and Invoice Status is Not Relevant

Symptom

You complete a Service Process in a Service Order or Sales Order and create a Service Confirmation as well as an Invoice, but the Service Order/Sales Order is not completed, because one Line Item has the Delivery Status is Not Started and Invoice Status is Not Relevant.

Environment

SAP Business ByDesign

Reproducing the Issue

This is relevant for both Service Order and Sales Order. We will use Service Order in our example:

  1. Go to the Service Orders work center.
  2. Select the Service Order Processing view.
  3. Open Service Order ABC (ABC represents the ID of the Service Order).
  4. Navigate to the Service and Spare Parts tab.
  5. Select Line Item XX (XX represents the Line Item ID).
  6. You can see that the Delivery Status is Not Started and the Invoice Status is Not Relevant.
  7. Navigate to the Document Flow tab.
  8. Open Service Confirmation XYZ (XYZ represents the ID of the Service Confirmation created for this Service Order).
  9. Navigate to the Service and Spare Parts tab.
  10. You can see that the Line Item YY (YY represents the Line Item ID in the Service Confirmation) which has the same product ID as Line Item XX in Service Order ABC has no value in the column Referenced Service Order/Item.

Cause

The Line Item YY in Service Confirmation XYZ was added manually in the Service Confirmation. Therefore the Line Item YY in Service Confirmation XYZ is not referenced to Line Item XX in Service Order ABC.

Since the item was added manually and has no reference to the Service Order the Delivery and Invoice Status of the Items in the Service Order are not Finished.

Resolution

 In order to resolve this issue and complete the Service Order, you will need to change or cancel the Follow Up Service Confirmation.

  1. To cancel or change the service confirmation follow KBA 2585089.
  2. When creating a new Service Confirmation, you need to ensure that the Items are all taken over from the Service Order and not added manually.

See Also

2585089 - How To Correct a Service Confirmation When The Status is Not Relevant

2616109 - Service Order Cannot be Completed as Invoice Status is Not Started.

Keywords

Service Order; Sales Order; Service Confirmation; Invoiced; Status; Completed; In Process; Referenced Service Order Item; Referenced Sales Order Item; Not Started Re , KBA , reference service order/item , reference sales order/item , AP-SVO-SO , Service Order , AP-SLO-SO , Sales Order , Problem

Product

SAP Business ByDesign all versions