Symptom
Nominators who send awards are unable to see them within sent awards.
Some users are able to see their sent awards and other are not.
**Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental**
Environment
- SAP SuccessFactors Rewards & Recognition
Reproducing the Issue
- Access the Rewards & Recognition home/landing page
- Select a program
- Search and select an eligible employee
- Select your categories, levels and award amounts
- Submit your award
- Go back into Rewards & Recognition and select "Sent Awards" under "My Awards"
- No awards will populate
Cause
This can be caused by two things.
- Permissions
- Employee Status field disabled
Resolution
As mentioned in the above section, this can be caused by two things. The following is how these causes can be checked.
Should you encounter this issue please ensure you have granted the nominator RBP for field "status" under "Employee Data".
- If you are unable to see this field here please check within Manage Business Configuration if the field is enabled.
- Go to Employee Profile> Standard
- Scroll down until you see status.
- Select the fields and ensure this is enabled.
- If this field is not enabled please enabled it, define a default label and save.
- Once saved go back to RBP and grant permissions for this field under Employee Data.
- Log out/in to the instance, access your sent awards and these should now populate.
To make sure this is not a permission issue we recommend a new role be created with the status permission given with a test group linked to it which includes the nominator.
Additional Information
You can use the browser developer tool to check the responses from our API's.
This would by using F12> Network Tab and looking at headers/responses.
In this case, we would see the call for spotAwards checking the nominatorId and their status being true or false from the User entity:
https://'HOSTNAME'/odata/v2/restricted/Attachment,GetEligibleSpotAwardsProgramCodesResponse,GetMatchedGuideLineRuleInfoResponse,InlineResult,IsUserEligibleForSpotAwardProgramResponse,
SendEmailToSpotAwardeeResponse,SpotAward,SpotAwardBudget,SpotAwardCategory,SpotAwardLevel,SpotAwardProgram,SpotAwardProgramAdvancedSettings,UpsertResult,User,UserSpotAwardsTotalResponse,UserTotalSpotAwardsMeta,
getEligibleSpotAwardsProgramCodes,getMatchedGuideLineRuleInfo,getUserSpotAwardsTotalInfo,isUserEligibleForSpotAwardProgram,sendEmailToSpotAwardee,upsert/
SpotAward?$format=json&$select=spotAwardProgram,externalCode,userId,category,level,awardAmount,approvalStatus,currency,approvedDate,commentForApprovers,
commentForReceiver,nominatorId,guidelineAmount,nominatorIdNav/defaultFullName,userIdNav/manager/userId,categoryNav/title_defaultValue,levelNav/title_defaultValue&$expand=nominatorIdNav,userIdNav/manager,categoryNav,levelNav&$orderby=createdDateTime desc&$filter=((nominatorId eq 'admin') and (nominatorIdNav/status eq 't' or nominatorIdNav/status eq 'f'))
You can use the following query as well to check the status using postman etc:
https://'HOSTNAME'/odata/v2/restricted/Attachment,GetEligibleSpotAwardsProgramCodesResponse,GetMatchedGuideLineRuleInfoResponse,InlineResult,IsUserEligibleForSpotAwardProgramResponse,SendEmailToSpotAwardeeResponse,SpotAward,SpotAwardBudget,SpotAwardCategory,SpotAwardLevel,SpotAwardProgram,SpotAwardProgramAdvancedSettings,UpsertResult,User,UserSpotAwardsTotalResponse,UserTotalSpotAwardsMeta,getEligibleSpotAwardsProgramCodes,getMatchedGuideLineRuleInfo,getUserSpotAwardsTotalInfo,isUserEligibleForSpotAwardProgram,sendEmailToSpotAwardee,upsert/User('admin')
If there is an issue with the status field or permissions, the response in both the browser and middleware will be as follows:
{
"d" : {
"results" : [
]
}
}
Should the query work correctly, you will see something as follows within the response:
"d" : {
"results" : [
{
"__metadata" : {
"uri" : "https://'HOSTNAME'/odata/v2/restricted/Attachment,GetEligibleSpotAwardsProgramCodesResponse,GetMatchedGuideLineRuleInfoResponse,InlineResult,IsUserEligibleForSpotAwardProgramResponse,SendEmailToSpotAwardeeResponse,SpotAward,SpotAwardBudget,SpotAwardCategory,SpotAwardLevel,SpotAwardProgram,SpotAwardProgramAdvancedSettings,UpsertResult,User,UserSpotAwardsTotalResponse,UserTotalSpotAwardsMeta,getEligibleSpotAwardsProgramCodes,getMatchedGuideLineRuleInfo,getUserSpotAwardsTotalInfo,isUserEligibleForSpotAwardProgram,sendEmailToSpotAwardee,upsert/SpotAward(28224L)", "type" : "SFOData.SpotAward"
}, "externalCode" : "28224", "approvalStatus" : "INPROCESS", "level" : "1", "nominatorId" : "admin", "spotAwardProgram" : "Disabled Award", "guidelineAmount" : "1000", "userId" : "employeeA", "approvedDate" : null, "awardAmount" : "1750", "currency" : "USD", "category" : "1", "commentForApprovers" : null, "commentForReceiver" : "dafsagdsgfdsagfeda", "nominatorIdNav" : {
"__metadata" :
If you still have issues viewing sent awards, please contact support.
NOTE
Please ensure the role assigned to users who're required to see their sent or received awards do not have the exclude granted user from seeing him/herself selected within target population.
If tihs is selected, the user will not see their history.
Keywords
unable to see sent awards, sent awards, rnr awards, nominator awards, manager unable to see awards, manager awards, r&r, my awards, sent awards not showing, missing awards , KBA , LOD-SF-RNR , Reward and Recognition , LOD-SF-CMP-SA , Spot Awards , Problem