Symptom
You are creating a Marketing Attribute of 'Time Format' with multiple values and Intervals. When entering the values in the Marketing Attribute, the time format is displayed as HHMMSS, instead of HH:MM:SS.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers workcenter.
- Go to the Accounts view.
- Open Account 123 (where 123 is the Account ID).
- Go to the Marketing Attributes facet.
- Here, for Marketing Attribute XYZ (XYZ is a marketing attribute with Format- Time format, Multivalue and Intervals allowed checkbox marked) maintain a value in format HH:MM:SS.
- Save the changes.
The error 'Enter the time in the format HHMMSS' is triggered.
Cause
Any time format field will always expect values to be terms of HHMMSS. Your expectation here is to have 2 time fields shown as one which is not possible.
When a range (interval) has been used, it is simply a 'input box' and not a Date/ Time field any more and hence it cannot have same formatting as time field. For the time fields, you can see a clock icon but Interval fields would be plain text field and we do not provide any clock icon nor any placeholder text like "h:mm:ss".
Resolution
This is the standard behavior of the system.
If this feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
Marketing attributes, time , KBA , LOD-CRM-BF-BA , Business Attributes , LOD-CRM-ACC , Account , Problem
Product
Attachments
| marketing attributes.png |
SAP Knowledge Base Article - Public