SAP Knowledge Base Article - Public

2833211 - Order of Line Items in Sales Document Does not Match Order In Excel

Symptom

You are uploading a sales document via the Excel Add-in.

The sales document is created, but the order of line items in the sales document is different from the order in Excel.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Use the Excel Add-in to create a Sales Order, Service Order or Sales Quote.
  2. Enter the relevant information in the template.
  3. Add multiple line items.
  4. Save the sales document to the system.

The order of line items in the sales document is different from the order in excel.

Cause

Due to a technical limitation on the Excel integration with SAP Business ByDesign, the order of uploaded items cannot be guaranteed when uploading Sales Documents using the Excel.

Resolution

As an alternative, it is possible to sort the line items directly in the sales document in the system, once it is created.

It can be done through the Items tab either by changing the line number manually or selecting the Up/Down arrows for each line item, and then sorting the list ascending or descending.

Keywords

Sales Order, Service Order, Customer Quote, Excel Addin, Kundenauftrag, Serviceauftrag, Angebot, Reihenfolge, Positionen, Excel, Integration, Order, Sequence, Numbering, Line Item, byd. , KBA , AP-RC-ANA-UI-XLS , C4C, ByD, Travel: Excel AddIn , AP-CQP-CQ , Customer Quote , AP-SLO-SO , Sales Order , AP-SVO-SO , Service Order , How To

Product

SAP Business ByDesign all versions