SAP Knowledge Base Article - Public

2833443 - Wrong User Interaction Step Type in Report End to End Response Time

Symptom

You are using the standard report End to End Response Time or a report based on the data source Response Time Analysis and you are checking the characteristic User Interaction Step Type. This field shows the entry Query when a user does a basic search in a work center. You expect that this report shows the entry Basic Search in that scenario.

Environment

SAP Cloud for Customer

Reproducing the Issue

As an example, perform the following steps with a business user:

  1. Go to the work center Sales, view Sales Leads.
  2. Perform a basic search, e.g. "All".
  3. Wait for a short while.
  4. Then perform an advanced search, e.g. expand the advanced search and filter for Status = Open.
  5. Wait for a short while.

Now perform these steps with the key user analytics:

  1. Go to the work center Business Analytics, view Design Data Sources.
  2. Search for the data source Response Time Analysis.
  3. Click Preview.
  4. In the selection, filter for today's date and the user who performed the steps above.
  5. Click Go.
  6. In the view, add the Time and the User Interaction Step Type.
  7. The step type shows "Query" for both actions that were performed.
  8. Click on the value help for User Interaction Step Type.
  9. It also offers the option Basic Search.
  10. You would expect that when you do a basic search (as opposed to an advanced search), this data source will show the user interaction step type Basic Search. 

Cause

The entry Basic Search in the User Interaction Step Type was added initially, however this functionality was not developed.

Resolution

As of now, both the basic search as well as the advanced search come up with the User Interaction Step Type as Query in this data source.

This feature is still in our produce backlog, however no commitment can be given if or when it might be released. You can register or vote for this idea on the Continuous Influence Session.

Keywords

response time, user logon data, report, business analytics, advanced search, basic, user interaction , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To

Product

SAP Cloud for Customer core applications 1908