Symptom
- Customer is using permanent time accounts for particular time account type.
- User was terminated and rehired this year, but account valid from on the time account is still the original hire date, and not the rehire date.
- Time Accounts were closed during the termination. However, during the rehire in the same period, the new time accounts were not created
Environment
SAP SuccessFactors Employee Central Time Off
Reproducing the Issue
- Associate was terminated and then rehired in the same year.
- The "Account Valid From" date on the permanent time account remains as original hire date, and is not reset to the rehire date.
- Accruals are also not recalculated - as Per the accrual rule, the user is entitled 2 days of this leave entitlement for the first year employment. For the Second year employment onwards, 4 days will be granted to him/her until reach 120 days max.
- You have to manually adjust the leave entitlement from 120 days to 4 days, as system is not considering the rehire as 1st year of employment.
- If you Close the Time Account of the user after termination. So during Rehire, system will not create New Time Account. This is not supported and you will have to reopen the old time account. Behavior is same for Recurring account scenario as well (If you close recurring account post termination, system will not create new account as already an account exists in that period. You will have to reopen the old time account).
Note: If at the time of rehire the time accounts for mentioned time account type do not exist for the user(were never created or were deleted), then the system creates a new time account with the rehire date - this is epxcted system behavior.
The system will always check the hire date at time of account creation, which during rehire is the new/rehire "hire date", not the previous / old hire date. Existing time accounts behave as outlined above - they are not updated.
Cause
This is considered a limitation for the termination / rehire scenario for permanent accounts.
Resolution
Please create an enhancement request via the community for this functionality.
There are existing ideas to improve termination end processing in the future. However, no target release date has been set/confirmed for these improvement suggestions.
Keywords
permanent time accounts, reset account validity on rehire, accruals are not recalculated after rehire, account validity not updated on rehire , KBA , LOD-SF-EC-TIM-TA , Time Accounts (TAT, TA, TAD) , LOD-SF-EC , Employee Central , Problem