Symptom
An import via API call is performed to update information and the workflow is not triggered.
Environment
- SuccessFactors BizX - all versions
- Integrations
- OData API
- Employee Central
- Imports
Reproducing the Issue
API:
1. API query to upload employee information;
2. Workflow is not triggered and no logs available in Business Rule Execution Log.
Employee Data import in the UI:
1. Download template in Import Employee Data;
2. Fulfill with the same information as the one on the payload of the API;
3. Import file in Employee Data;
4. Workflow is not triggered and no logs available in Business Rule Execution Log.
Cause
Currently Imports (API or UI imports) do not trigger workflow without an approver.
Resolution
Review the workflow and verify if there is an approver since the workflow will only be triggered if there is one.
If no approver is needed, it will be needed to evaluated if it is possible to disable the workflow.
Keywords
Workflow not triggered; send e-mail; email; import; API; OData; SFAPI; Without approver; templates; Document Generation; fail. , KBA , LOD-SF-INT , Integrations , LOD-SF-INT-API , API & Adhoc API Framework , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , How To