SAP Knowledge Base Article - Public

2835858 - Error message when changing the StartDate in I9OutOfCompliance - Onboarding 1.0

Symptom

Hiring Manager is trying to change the Start Date for some candidate in I9OutOfCompliance_ChangeStartDate and the following error message appears:

The following fields are required and must be filled in before you continue:

- The Start Date you selected does not provide enough time to complete the I-9 Verification, which is required within the first three (3) days of employment. Also, the Start Date cannot be more than 120 business days from the current date. Please return to the panel and change the Start Date. "

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.   

Environment

SAP Successfactors Onboarding 1.0

Reproducing the Issue

  1. Go to Onboarding;
  2. Take one activity in Orientation Step;
  3. Try to change the StartDate for a past date
  4. The following error appears:

2019-09-06_09-37-47.png

 

Cause

It's expected behavior for OutOfCompliance panels. By default, the new start date can be at maximum your current calendar date minus three business days and at maximum 30 business days from the current date.

Resolution

Use a Start Date that matches with this time range.

Keywords

StartDate, Change, I9OutOfCompliance, I9, Reverification , KBA , LOD-SF-OBD , Onboarding , Problem

Product

SAP SuccessFactors Onboarding