Symptom
When you change the Time Offset of your Scheduled Workflow Rule, the business objects that have this rule scheduled are not updated based on the new time offset.
Environment
SAP Cloud for Customer
Reproducing the Issue
We will consider that you have a schedule workflow rule ABC (ABC represents the Workflow Rule ID) with Time Offset of 10 days before Opportunity Close Date. Also, that you have an Opportunity DEF (DEF represents the Opportunity ID) which has this rule already scheduled for 10 days before the Close Date.
- Go to the Administration work center.
- Go to the Workflow Rules tab.
- Click on Edit icon of workflow rule ABC.
- Change the Time Offset to 15 days.
- Save your change.
- Go to the Sales work center.
- Go to the Opportunities view.
- Open the opportunity DEF.
- Go to the Workflow Changes facet.
- The Schedule Time remains 10 days instead 15 days.
Cause
The Schedule Workflow Rule is not re-triggered in the business objects automatically when you do any change in the workflow. Therefore, the business objected is not updated with the new Time Offset.
Resolution
This is the expected system behavior.
You need to perform any change in the business object maintaining the workflow rule condition as true, in order to update the scheduled date.
Further, the offset time cannot be passed.
Keywords
Scheduled Workflow Rule, Time Offset , KBA , LOD-CRM-WKF , Workflow , How To