Symptom
Users were added in Employee Central via mass upload however, not all users were synced to Onboarding.
Environment
SAP SuccessFactors All Environments - Onboarding 1.0
Reproducing the Issue
1. Add/upload users in EC.
2. Check employee export for if users were successfully uploaded.
3. Run a full sync Delta User sync/User sync.
4. Check the users in onboarding > Security Users.
5. See that not everyone were synced.
Cause
1. Some users were not synced to onboarding due to no email address included in the Delta sync report.
2. The key HRDataService.SyncUser.CheckExistenceOfEmail in Superadmin Account Option is set to True.
Resolution
- add the users' email address in the user sync report. ;or
- Check if the key HRDataService.SyncUser.CheckExistenceOfEmail in Superadmin Account Option is equal to True. If it is, set to False.
Keywords
Delta User Sync Job, User Sync Report, HRDataService.SyncUser.CheckExistenceOfEmail, Account Option, Superadmin, Email Address, Integration_Fail , KBA , LOD-SF-OBD-ADM , Admin Tools, Settings, Permissions , Problem