Symptom
Advance configuration has 'Employee can Edit Number of Installments' set to 'Yes' but the during the claim the employee cannot actually edit the number of installments.
The field on the Object and UI is set to editable and the employees have the relevant permissions.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.“
Environment
Employee Central - Advances & Deductions
Reproducing the Issue
1. Go to My Employee File
2. Go to Eligibility For Advances
3. Go to Advance
4. Request Now
5. Number of Installments field is not editable
Cause
This is currently a known issue in the b1908 release.
Resolution
The issue has been patched in b1908p5 for manage data.
The issue still occurs via ESS or via enrolling via people profile. This is caused by the UI for controlling the editiability of the field not have a UI rule trigger
Please do the following to fix this:
1. Go to Manage Configuration UI
2. Search for UI AdvanceConfigUI
3. Click on edit properties just below the config UI screen
4. Add UI rule setInstallmentCountEditability as an onInit UI rule and save.
Field is now editable.
Keywords
BEN-4413,BEN-4481, Advances, Advance, Deduction, Deductions, Number, of, Installments, field, not, editable, Employee can Edit Number of Installments, Yes, Request, Now , KBA , LOD-SF-EC-ADV , Advances , LOD-SF-EC-DED , Deductions , Problem