SAP Knowledge Base Article - Public

2838803 - Business Unit, Division, and Department Filters for Position Workflows are not available since b1908

Symptom

The Business Unit, Division, and Department Filters in My Workflow Requests Professional Edition are disabled for Position Workflows.

My Workflow Requests.jpg

*Image/data in this KBA is from SAP Internal Systems, sample data, or Demo Systems. Any resemblance to real data is purely coincidental.*

Environment

SAP SuccessFactors Employee Central - Workflows

Reproducing the Issue

  1. Log in as a Manager with Pending Workflows and access to My Workflow Requests Professional Edition
  2. Click on the Approval Requests To Do Tile.
  3. Click on Go to My Workflow Requests.
  4. In the Request Type, select Change Generic Object Actions.
  5. Notice that Business Unit, Division, and Department Filters are disabled and cannot be used.

Cause

Starting b1908, Business Unit, Division, and Department Filters in the My Workflow Requests Professional Edition are disable for Change Generic Object Actions Workflow Types. 

Resolution

With the changes in b1908, the Business Unit, Division, and Department have also been disabled even for Position Workflows as these are considered as Change Generic Object Actions Workflow Type. There is an opened Enhancement Request (ECT-124274) with Engineering Team to add these Filters back for Position Workflow Types.

There is no timeline for this Enhancement Request at this time. Please monitor this JIRA for future updates.

Keywords

Position Workflows, Change Generic Object Actions, Business Unit, Division, Department, Filters, Professional Edition, My Workflow Requests, Workflow Filters, ECT-124274, ECT-117138, Professional Edition Manage Workflow Requests , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , Product Enhancement

Product

SAP SuccessFactors Employee Central 1908