SAP Knowledge Base Article - Public

2838843 - Rule Type Action Is Not Available when Setting a Workflow Rule for Custom BO

Symptom

The user is configuring a workflow rule for a custom BO  created from SDK and the Rule Type "Action" is not available to be selected when defining the actions.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the Workflow Rules work view.
  3. Click on New.
  4. On step 1 - Enter Basic Data, for Business Object, select a custom BO.
  5. Define the Conditions accordingly on the step 2.
  6. On step 3 - Define Actions, select the Rule Type.

Result: The "Action" is not available.

Cause

Rule Type "Action" is not support for custom BO.

Resolution

The user should select the available Rule Type when a workflow is defined. As this is a custom BO, the user can evaluate a feasible solution which will execute the needful action instead. Otherwise partner can create a custom action in SDK in the same custom BO and use it accordingly.

Keywords

Rule type "Action" Custom Approval Process , KBA , action not available in rule type , action missing in workflow for custom , AP-RC-BDS-BTM , ByDesign Studio Business Task Management , How To

Product

SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions