Symptom
There is no option available to add Products in Promotions.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Sales Campaign workcenter.
- Go to the Promotions view.
- Open Promotion 123 (where 123 is the Promotion's ID).
- Navigate to the Products facet.
You cannot find any option to add Products and you expect that 3 tabs are shown: Products, Product Categories, and Product Groups.
Cause
You have not selected a value for the field 'Product Planning Basis'.
Resolution
To add products to your promotions (and consequently see the tabs), you must select a Product Planning Basis.
- Open the relevant Promotion 123.
- On the header, enter edit mode.
- Under General Information, maintain a Product Planning Basis for your promotion.
Depending on your configuration you can add a Product, Product Category, Product Group as well as combinations of these options from the menu.
Once you have chosen an option here, you can add items to your promotion.
Please note that the UI in your system might differ from the depction below.
Keywords
Add Missing, No products , KBA , LOD-CRM-PRM , Promotions , Problem
Product
Attachments
promotion.png |