SAP Knowledge Base Article - Public

2842141 - People Scope not appearing in runtime filters even when 'User Prompted People Scope' is checked - Detailed Reporting

Symptom

A Cross Domain Detailed Reporting report, in which  People Scope is set to be selected during runtime (by checking 'User Prompted People Scope'), does not display option for selection of 'People Scope' in runtime filter pop-up dialog

Environment

  • SAP SuccessFactors HCM Suite
    • Online Report Designer / Report - Canvas : Advanced reporting

Reproducing the Issue

  1. Create a Report - Canvas
  2. Add a List report Component
  3. Edit Query
  4. Select 'Detailed Reporting' > New
  5. Design query to include fields from a domain which supports People Scope and from one that does not
  6. From Edit > People Scope > check 'User Prompted People Scope' 
  7. Save
  8. Run the Report from Report Center
  9. See if option to set People Scope is displayed in the runtime filter pop-up dialog

Cause

If the initial domain (of the two domains) to build a cross-domain report does not support/have People Scope, then runtime filter does not show the option to set People Scope during runtime.

Resolution

  • Go to Report Center > Edit the Report > Select Component > Edit Query > click on Edit menu > select Relationship Scope 
  • See which is the first domain (the one to the left)
  • If the first domains does not have People Scope, then it will not display 2nd domains People Scope in runtime filters even if 'User Prompted People Scope'  is selected.
  • Edit the report and interchange the domains by building the report from scratch. Make sure to have domain that supports people scope as the first domain. 

Keywords

report, canvas, people, scope, selection, select, unavailable, runtime, run, time, filter, filters, summary, ord, detailed, reporting, live, data , KBA , LOD-SF-ANA-ORD , Online Report Designer , Problem

Product

SAP SuccessFactors HCM suite all versions