SAP Knowledge Base Article - Public

2842310 - Due Date is not determined accurately in Customer Statement in 'Schedule Accounts Receivable Jobs' app

Symptom

While executing Customer Statement using 'Schedule Accounts Receivable Jobs' app, the Due Date is displayed as 00T00:00:00 instead of the actual date. The due date is determined correctly when executing the customer statement using 'Create Correspondence' app.

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Environment

  • Financial Accounting (FI)
  • SAP S/4HANA Cloud
  • SAP Fiori 

Reproducing the Issue

  1. Goto app 'Schedule Accounts Receivable Jobs'.
  2. Create new Job with template "Correspondence: Customer Statement".
  3. In the parameters session, provide recipients details.
  4. In Advance Parameters session, select Parameter Source as Entered Manually and provide the advanced parameters.
  5. Schedule the job

Cause

The due date is not displayed in the output of the scheduled job for Customer statement is because the field "Standard Key Date for Due Dates" is set as blank in the parameter for the job. When the field is set to blank, system is unable to calculate the due date as there is no standard key date mentioned. In Create Correspondence app, the field "Standard Key Date for Due Dates" is defaulted to 1(Upper date limit of account statement).

Resolution

Select an option from the F4 help for the parameter 'Std. Key Date for Due Dates'.

Std. Key Date for Due Dates.jpg

options.jpg

Keywords

FI-FIO-AR, CA-GTF-FXU-FI-AR F2366, F0744, Correspondence, Customer, Standard, statement date, Due date, Arrears on date, Overdue, FIN_FO_CORR_CUS_STAT, SAP13, FI, S4_PC , KBA , FI-FIO-AR , Fiori UI for Accounts Receivable , FI-FIO-AR-2CL , Fiori UI for Accounts Receivable (Public Cloud) , CA-GTF-FXU-FI-AR , Fiori FXU Accounts Receivable FI-FIO-AR , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions