Symptom
Error on updating National ID Information
Environment
SuccessFactors - Employee Central
Reproducing the Issue
- Go to Employee Profile of user recently Hired.
- Try to insert National ID information
- Error Message: fingerprint=a0c44c67099916942cf8eaa55d57e7a4653a7adc
Cause
There are validations done to check the correctness of the value provided for national Id field.
The gender field from the personal Information details is needed as of the date of upsert.
Resolution
This is being caused as the gender field has not yet been set for this users profile and this is needed for the deep national ID validations. To fix this issue, you need to do one of the following:
- Set the gender for the future dated hire
- Disable validations temporarily and populate the National ID portlet
- Wait until the user becomes active and populate National ID information then
Keywords
a0c44c67099916942cf8eaa55d57e7a4653a7adc, National ID, Error, Validation, EmpPersonalInfoEO.getGender , KBA , LOD-SF-EC-HIR , Hire & Rehire Wizards , LOD-SF-EC , Employee Central , Problem