Symptom
You are creating a new Visit from an Opportunity and you wish to change the Account; in the Account OVS you do not see all Accounts but only one.
Environment
SAP Sales Cloud
Reproducing the Issue
-
Go to the Sales workcenter.
- Go to the Opportunities view.
- Open Opportunity ABC (ABC stands for an Opportunity name).
- Go to the Sales Activities facet.
- In the Visits section, click New to create a new Visit.
- Click the value help for the Account to change the Account: only one Account 123 (123 stands for the Account ID) is shown instead of all.
- Repeat the above in another Opportunity XYZ: here all Accounts are shown.
Cause
The Opportunity ABC has a Contact assigned which has a relationship with the 3rd Account 123. The Opportunity XYZ does not have a Contact assigned.
The Account list in a Visit is related to the Contact of the Visit, hence in a new Visit, when a Contact is assigned to the Opportunity (and hence automatically to the new Visit), only the Account/s related to the Contact is listed.
Resolution
This is the designed system behaviour.
In order to see if a Contact is automatically assigned to the new Visit, please add the Primary Contact field to the Visit Quick Create.
Keywords
opportunity, visit, account, contact , KBA , LOD-CRM-OPP , Opportunity Management , Problem