SAP Knowledge Base Article - Public

2842350 - No Approval history maintained in the Approval facet inside an Opportunity

Symptom

You define an Approval Process for opportunities. When the conditions are met, you are able to send an opportunity for approval and approve it. After that, you change some fields in the opportunity, which will make the approval process begin again. You expect that a new line will appear in the Approval facet (as the opportunity was already approved before and you wish to keep track of the approval history). However, the system deletes the previous approval with status "Approved" and displays a new one with status "Approval Not Started".

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Administration work center.
  2. Go to the Approval Process.
  3. Define an Approval Process for Opportunities.
    For instance, you can define that if an opportunity has Sales Phase=Z03, we should be able to send it for approval.
  4. Activate the Approval Process.

  5. Go to the Sales work center.
  6. Go to the Opportunities view.
  7. Create an Opportunity with the conditions maintained in the Approval Process.
  8. Send the opportunity for approval.
  9. Ask the approver to approve the opportunity.
    RESULT: You will see a new row in the Approval facet with status "Approved".

  10. Modify a field defined in the Approval Process so that the previous approval isn't valid anymore.
    RESULT: You will see that the previous row has disappeared and a new row is now displayed with status "Approval Not Started".
    EXPECTED BEHAVIOUR: You would expect one row with status "Approved" and another row with status "Approval Not Started".

Cause

You have switched on the scoping "Approved opportunities re-approval". The scoping overview states: "When you make a change to approval relevant fields in an approved opportunity, the approval status will be reset to ‘Not Started’. The approval process can be re-triggered if the changes fulfill predefined approval conditions."

 ReApproval.png

Resolution

You can deactivate in scoping the option "Approved opportunities re-approval" if this functionality is not desired.

Keywords

approval process, approval history, opportunity, approval facet, re-approval, scoping, Approval Not Started, Approved , KBA , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 1908