Symptom
The following error message occurs when trying to invoice an Invoice Request for example a Service Confirmation Invoice Request: 'Invoicing not permitted for request XYZ (Service Confirmation); request is locked'. (XYZ represents the identification of an invoice request such as a Service Confirmation Invoice Request)
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Customer Invoicing work center.
- Go to the Items to be Invoiced or Invoice Request view.
- Select the invoice request XYZ.
- Click on the Invoice button.
The following error message is triggered: Invoicing not permitted for request XYZ (Service Confirmation); request is locked.
Cause
Inconsistencies can be triggered for different reasons:
- Tax calculation is not applied correctly.
- Inconsistent Master Data for a Business Partner used in the reference document, for example, the Account.
- Payment Terms are not set up correctly in Business Configuration.
- An Invoice Block is maintained in the source document like a Service Order, Sales Order or Contract.
- The Invoice Request or the document on which the Invoice Request is based on is locked by a user.
Resolution
The redetermination should be done on the Service Order Invoice Request or any related preceding invoice documents, such as Sales Order Invoice Request or Customer Contract Invoice Request:
- Go to the Customer Invoicing work center.
- Go to the Invoice Request view.
- In the Search field, enter the Service Order DEF (DEF represents the identification of the service order for the Invoice Request XYZ).
- Select the Service Order Invoice Request which is inconsistent.
- Click on the Check button.
This displays the Identified Issues why the invoice request is inconsistent. - Solve the issues identified in the screen.
- Select Redetermine or Redetermine All if there are multiple items.
- Go back to the Invoice Request view.
- Select Invoice request XYZ to be invoiced.
- Click on the Invoice button to proceed with the invoicing.
In case there is an Invoice Block maintained in the source document, there will not be any results using the Check functionality. The Invoice Block must be removed in the source document (as the Service Order, Sales Order or Contract). Once this is done and the changes are saved, the Invoice Request will not be blocked anymore and it will be possible to invoice it.
In case the Invoice Request or the document on which the Invoice Request is based on, is locked by a user, the user can be found out by opening the Invoice Request or the document on which the Invoice Request is based on via the Edit button. The system will display the user locking the document in the error message.
See Also
Keywords
inconsistent; invoice request; locked; , KBA , AP-CI-CIR , Customer Invoice Request , How To