Symptom
Custom Fields created from the 'Custom Fields and Logic' app for Business Context 'Marketing: Permission' are not appearing in the SAP Fiori Contact Profile.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP Marketing Cloud Edition
Reproducing the Issue
- Create a Custom Field for the 'Marketing: Permission' business context in the 'Custom Fields and Logic' app and enable the field for the 'Contact Profile' usage
- Open a contact using the Fiori Contact Profile and observe the newly created field is not appearing in the 'Permission Marketing' tab
Cause
Custom fields are available in the Marketing Permissions table view but need to be inserted first.
Resolution
The custom field needs to be inserted using the table columns settings .
After the custom field is enabled it will appear in the Permissions table view.
For using the custom field for the Contacts Profile app, the usage 'CUAN_CONTACT_SRV 0001 - Contact Profile' is required. For using the custom field for Spotlighting Accounts app, the usage 'CUAN_ACCOUNT_SRV 0001 - Spotlighting Accounts' is required.
For both apps, the custom field is available for the table view only, but not for the tile view.
Keywords
Custom Fields and Logic, Marketing: Permissions, Contact Profile Benutzerdefinierte Felder und Logik, Kontaktprofil , KBA , CEC-MKT-DM-PER , Marketing permissions , CEC-MKT-DM-CON-FAC , Contact/Account Factsheet , Problem