Symptom
You would like to add Employee field to the ticket header (General Information section) in Fiori but the field is not available to be added.
Environment
SAP Service Cloud
Reproducing the Issue
- Logon using Fiori client.
- Go to the Service work centre.
- Go to the Tickets view.
- Open a ticket.
- Go to the Overview facet of the ticket.
- Option 1:
- Select Start Adaptation option from the user profile menu.
- Select pen button for the General Information section.
- Field Employee is not available to be added.
- Option 2:
- Select Open layout in HTML5 option from the user profile menu.
- Click Adapt button.
- Select Edit Master Layout.
- Select + button to add field on the header section.
- Field Employee is not available to be added.
Cause
The field is not available on the header (General Information) but can be moved from the Employee section.
Resolution
To move the field from the Employee section, follow the below steps.
Prerequisite: Employee section is already added to the ticket Overview facet.
- Logon using Fiori client.
- Go to the Service work centre.
- Go to the Tickets view.
- Open any employee support ticket.
- Go to the Overview facet of the ticket.
- Option 1:
- Select Start Adaptation option from the user profile menu.
- Select pen button for the Employee section.
- Select field Employee.
- Select Move button.
- Move the Employee field from the Employee section to the General Information section.
- Select End Adaptation option from the user profile menu.
- Option 2:
- Select Open layout in HTML5 option from the user profile menu.
- Click Adapt button.
- Select Edit Master Layout.
- Drag and drop the field Employee from the Employee section to the header section.
- Select End Layout Changes option from the user profile menu.
See Also
If the Employee field is grayed out, refer to Knowledge Base Article: 2818171 - Unable to make fields visible via Fiori Adaptation.
Keywords
ticket, employee, field, adapt, add , KBA , LOD-CRM-SRP , Service Request Processing , How To