Symptom
You made a change to a field like Function, Department, Phone or E-Mail on the header of a contact, but the Changed On field does not change its value.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers work center.
- Go to the Contacts view.
- Open contact ABC (ABC represents the contact ID).
- Enter edit mode.
- Make any change to the E-Mail field on the contact header.
As you see, the value of the Changed On field is not changed.
Cause
The underlying business object for a contact is the BO BusinessPartner where attributes like name, etc. are stored. But the e-mail address and other fields like Function, Department, Phone, and so on, are relationship dependent and are therefore stored in the BO BusinessPartnerRelationship.
Resolution
In the contact TI we show in the header "changed on" of the BO BusinessPartner, not the "Changed On" of the BO BusinessPartnerRelationship. In the contact TI Changes facet we show all the changes independent if the BO BusinessPartner or BO BusinessPartnerRelationship was changed.
Keywords
Contact, Change, Function, Department, Phone, E-mail , KBA , LOD-CRM-CON , Contact , How To