SAP Knowledge Base Article - Public

2843772 - Changes made to E-Mail, Function, Department, Phone and others on a contact, do not affect the Changed On field

Symptom

You made a change to a field like Function, Department, Phone or E-Mail on the header of a contact, but the Changed On field does not change its value.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Contacts view.
  3. Open contact ABC (ABC represents the contact ID).
  4. Enter edit mode.
  5. Make any change to the E-Mail field on the contact header.

As you see, the value of the Changed On field is not changed.

Cause

The underlying business object for a contact is the BO BusinessPartner where attributes like name, etc. are stored. But the e-mail address and other fields like Function, Department, Phone, and so on, are relationship dependent and are therefore stored in the BO BusinessPartnerRelationship.

Resolution

In the contact TI we show in the header "changed on" of the BO BusinessPartner, not the "Changed On" of the BO BusinessPartnerRelationship. In the contact TI Changes facet we show all the changes independent if the BO BusinessPartner or BO BusinessPartnerRelationship was changed.

Keywords

Contact, Change, Function, Department, Phone, E-mail , KBA , LOD-CRM-CON , Contact , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions