SAP Knowledge Base Article - Public

2844023 - Service Order Cannot be Completed since the Invoice Status of an Item is Not Started.

Symptom

You are not able to complete a Service Order since an Item is not completed. The Invoice Status of the Item is Not Started but there is no Invoice Request available for this Item even though the Delivery Status is Finished.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Service Orders work center.
  2. Select the Service Order Processing view.
  3. Open Service Order XYZ (XYZ represents the service order ID).
  4. Go to Services and Spare Parts tab.
  5. Select Line Item XX (XX represents the line item number).
  6. You can see that the Delivery Status is Finished and the Invoice Status is Not Started.
  7. You created a Service Confirmation ABC for this Line Item but there is no Invoice Request in the Invoice Request view in order to invoice this item and finish the Invoice Status (ABC represents the ID of the service confirmation).

Cause

For Line Item XX of Service Order XYZ the Non- Billable checkbox is not active. However, in Service Confirmation ABC the Non- Billable checkbox is active for the Reference Service Order/Item XYZ – XX.

Since the Non- Billable checkbox is active for the Item in Service Confirmations ABC the Service Confirmation Invoice Request is not created.

However, in the Service Order XYZ the Line Item XX is marked as billable since the Non- Billable checkbox is not active and therefore the Service Order expects and Invoice for this item to complete the process and change the Invoicing status to Finished. Since in this case for Line Item XX in Service Order XYZ the execution was completed no further Service Confirmations can be created.

Resolution

To solve the issue, you need to cancel the Service Confirmation and create a new Service Confirmation for which the Non- Billable checkbox is not active. Then the Service Confirmation Invoice Request will be created, you can invoice it and the Invoicing Status will be finished which in turn means that the item will be completed.

The implementation of a check to ensure that the execution can only be completed for a billable item if there is at least one billable Service Confirmation available has been added as a new requirement to the Product Backlog in order to enhance the functionality with this feature in one of the future product releases.

Keywords

Status; Service Order; Not Started; Invoice Request; missing; Billable , KBA , AP-SVO-SO , Service Order , Problem

Product

SAP Business ByDesign 1908