Symptom
In the stacked bar/column chart with a time dimension year on the X Axis within a story, if apply the sort order Earliest to Latest for the year, the custom order defined for the color dimension in the chart will be broken, and even for the default sort order, sort descending and sort ascending, same issue also happens.
Environment
- SAP Analytics Cloud
Reproducing the Issue
- Create story in SAC and insert a Stacked Bar/Column chart.
- Add one dimension and measure to the chart.
- Add one dimension to the color.
- Select the chart and click sort options, then select the dimension used for the color and click Add Custom Order...
- Define the custom order, like changing the dimension order to a different one than the default alphabetical order, then apply the order to the chart.
- Click the sort options and select the dimension in the X axis, set the order to Earliest to Latest.
- Notice that the custom order defined for the color dimension is broken.
Cause
This behaviour is a product limitation. The chart can only honor what the query returns. The unbooked members of a dimension may not return in a query so they may locates behind the booked members even they are set to show before the booked members.
Resolution
An enhancement request has been created and you can vote for it: https://influence.sap.com/sap/ino/#/idea/239693/?section=sectionDetails
Some possible workarounds:
- Enabling the 'unbooked data' option from the ... menu for the corresponding dimensions in your chart in the designer panel.
- Use a calculation to replace any null values with 0 so that a value is included in the resultset returned from the back-end. One example of a such a calculation (non-BW datasources) is:
IF (ISNULL (["ProfitAndLoss":Gross Margin]), 0 , ["ProfitAndLoss":Gross Margin] )
Note: In both cases above, the Top N (Auto) may be triggered, so you may need to manually override the Top N to a higher value, or filter the chart further to avoid it.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an incident for SAP Analytics Cloud?
- SAP Analytics Cloud > Learning > Guided Playlists
- SAP Analytics Cloud > Learning > Guided Playlists > Getting Support
- Need More Help? Contact Support or visit the solution finder today!
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Keywords
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