SAP Knowledge Base Article - Public

2845033 - Files Attached while Answering a Survey Are Not Maintained in the Attachments Table

Symptom

The files attached during "Runtime Attachment" while answering a survey for a visit, are not maintained in the Attachments table of the Surveys facet.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Visits work center.
  2. Open the visit for which you have maintained a survey with "Runtime Attachment" selected on the question.
  3. Go to the Surveys facet.
  4. Open the survey.
  5. Attach a file to the question.
  6. Submit the survey.

The attached file during survey runtime is not maintained on the Attachment table under the Surveys facet.

Cause

Only attachments added at Product level will be visible in the Attachments table. The Products table and Attachments table have a linkage. Only on selection of the Product will the relevant attachment show up. If for a product there was no attachment added then on selection of that product row, the table will render empty. Basically, this is dynamic rendering based on the Product.

The question level attachments cannot be viewed in the Attachments table but can be viewed in the Related Attachments work center view.

Resolution

This is the standard behavior of the system.

If the feature/functionality is needed as a matter of urgency, please refer to KBA
3475641 - Functionality Currently not Available.

Keywords

KBA , LOD-LE-SUR-EXE , Survey execution = runtime , How To

Product

SAP Cloud for Customer core applications 1908