SAP Knowledge Base Article - Public

2845077 - Enter Results in Double Spaces Within the Email Editor

Symptom

When writing an email within a Ticket (using the standard email editor), when the Enter keyboard button is pressed, the system adds double lines.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Service work center.
  2. Select the Tickets view.
  3. Open Ticket ABC (ABC represents the Ticket description).
  4. Go to the Interactions facet.
  5. Click on New to add a new email, or click on Reply to reply an existing email.
  6. In the email editor press Enter, double lines will be added.

Cause

The standard interaction feature uses a third party tool (Kendo editor).

The Kendo editor has been designed with the following logic:

  • Enter = new line with a space (paragraph).
  • Shift+Enter = New line without any spaces between the lines.

Resolution

To add a new line next to the last line, instead of pressing the button Enter, the Shift+Enter option should be used.

Keywords

Enter; Email; Editor; Kendo; , KBA , LOD-CRM-SRP-INT , Ticket Interactions , How To

Product

SAP Cloud for Customer core applications all versions