SAP Knowledge Base Article - Public

2845539 - Some fields in the application are not visible to the applicant and/or the operators - Recruiting Management

Symptom

Some fields in application are not visible to the candidate applying and/or the operators of the job requisition, although the permission is correctly configured in the application/job requisition template.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Recruiting Management

Cause

These are the possible causes:

Cause 1:

No country is configured in the job requisition. The fields in application are configured as public="false" and an override is configured to set it to public="true". However, the overrides are dependent of the field country in the job requisition. Since there isn't any countries configured, the fields are not showing up.

Cause 2:

If multi-stage application is enabled, read and write permission is not provided in specific status.

Cause 3:

If the job requisition is created via Position Org Chart, the field "appTemplateId" might have been mapped to an incorrect template ID in the business rule.

Resolution

For cause 1:

  • If you have the permissions to see and edit this field, manually edit it through the Job Requisition Details page. If you don't have the permissions to see this field, you might want to consider with your team if someone can have the permission to change it in the template, then manually change it;
  • You can also change it using SFAPI/OData.

For Cause 2:

Once confirmed that country field is correct, check the Job Requisition template to validate if the candidate or operator has write or read permission to application fields in specific status.

Note: We cannot make the application field visible in Forwarded and Invited to Apply status (recruiter view). The only infomation they can see in these statuses are Candidate Profile information. Application field will start to show in Default status.

For Cause 3:

  1. Navigate to Position Management Settings > Integration tab.
  2. Edit the "Field Mapping Rule to Create Job Requisition from Position".
  3. Remove the mapping for "appTemplateId" or correct the value.

There is no need to map the appTemplateId as the system will pull the job application template associated with the job requisition template automatically.

It is not supported to use the appTemplateId which is not associated with the job requisition template.

appTemplateId.png

Keywords

country, application, fields, field, not, visible, cannot, see, showing, filled, multi, stage, multistage, multi-stage, permission. , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Problem

Product

SAP SuccessFactors Recruiting all versions