SAP Knowledge Base Article - Public

2845971 - Error 'Business Partner Role Cannot Be Changed' During Upload of a Workforce Person Data Using the Import Employee app

Symptom

The error message is displayed while uploading workforce person data using the Import Employee app. ‘Worker: <person external ID> - <role> cannot be changed.' (Message number 020 (wfd_employee_upload).

Environment

SAP S/4HANA Cloud

Cause

You get this error message when you try to change the role of a workforce person. The Import Employee app does not support role changes.

Resolution

If you want to change the role of a workforce person, use the SOAP API.

Keywords

KBA , CA-WFD-INT , S/4HANA Cloud Workforce Domain Integration , CA-HR-S4 , Cross-Application HCM Objects in S/4HANA , How To

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions