SAP Knowledge Base Article - Public

2846651 - User Is Not Able to See Work Center View

Symptom

You notice that a user assigned to a Business Role has all the required rights and roles to access a Work Center View, but is not able to see it when logged into the system.

Environment

SAP Cloud for Customer

Reproducing the Issue

We will consider that a user has all the required rights and roles to access the Activities work center, but still can't see the Emails and Phone Calls views.

  1. Log into the system with the relevant user who should have access to the views.
  2. Go to the Activities work center.
  3. You cannot find the Emails and Phone Calls views.

Cause

The work center views have been made invisible using the "Organize work centers and work center views" that you can find in the Administrator work center -> General settings.

Resolution

You should mark these work center views as allowed under "Organize work centers and work center views" on Administrator work center following below steps:

  1. Go to the Administration work center.
  2. Go to the General Settings.
  3. Click "Organize work centers and work center views".
  4. Select the relevant entry. 
  5. Find the work center the view belongs to and select. 
  6. Check the box, to mark it as allowed. 
  7. Save and close.

OrgWocView KBA1.png

Optionally you can leave the settings as they are, but unassign the role.

  1. Go to the Administration work center.
  2. Go to the General Settings.
  3. Click "Organize work centers and work center views".
  4. Select the relevant entry.
  5. Click 'Assign'.
  6. Remove any business role which should see the view.
  7. Save. 

assignKBA.png

Note, for both above options, the users have to log out and back into the system for changes to take effect.

See Also

missing, woc view, cannot see, vanished

Keywords

Work Center, View , KBA , rbam , AP-RC-UIF , C4C UI Framework , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions