Symptom
You notice that a user assigned to a Business Role has all the required rights and roles to access a Work Center View, but is not able to see it when logged into the system.
Environment
SAP Cloud for Customer
Reproducing the Issue
We will consider that a user has all the required rights and roles to access the Activities work center, but still can't see the Emails and Phone Calls views.
- Log into the system with the relevant user who should have access to the views.
- Go to the Activities work center.
- You cannot find the Emails and Phone Calls views.
Cause
The work center views have been made invisible using the "Organize work centers and work center views" that you can find in the Administrator work center -> General settings.
Resolution
You should mark these work center views as allowed under "Organize work centers and work center views" on Administrator work center following below steps:
- Go to the Administration work center.
- Go to the General Settings.
- Click "Organize work centers and work center views".
- Select the relevant entry.
- Find the work center the view belongs to and select.
- Check the box, to mark it as allowed.
- Save and close.
Optionally you can leave the settings as they are, but unassign the role.
- Go to the Administration work center.
- Go to the General Settings.
- Click "Organize work centers and work center views".
- Select the relevant entry.
- Click 'Assign'.
- Remove any business role which should see the view.
- Save.
Note, for both above options, the users have to log out and back into the system for changes to take effect.
Keywords
Work Center; View; Missing; Woc View; Cannot See; Vanished; Disappeared; Hidden; Template; Service; Tickets; Registered Products; E-mails; Emails; Work Tickets; Activities; Live Activity; Installation Point; Installed Base; OData; Odata; Workflow Rules; Administrator; Sales Order; Unassociated Emails; Territories; Ticket Hierarchy; Maintenance Plans; Time Recording; Time Entries; Time Reports; Service and Social; Web Service Message Monitoring , KBA , rbam , AP-RC-UIF , C4C UI Framework , How To