SAP Knowledge Base Article - Public

2847066 - Search Results Component in Category page is not accessible

Symptom

Nothing happens when clicking on the Search Results "Component" in a category page.

Search results.png

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors Recruiting Marketing
  • Career Site Builder

Reproducing the Issue

  1. Open the CSB configuration
  2. Open the Pages menu
  3. Open the Category menu
  4. Select and Edit a category page
  5. Click on the Search Results Component image on that page 
  6. Nothing happens

Cause

The Search Results is not an actual component but a placeholder present by default on every category page as soon as they are created since every category page by definition should have a results section.
As a result, it cannot be configured like the other components can by clicking on it.

Resolution

The Search results options are configured under Appearance / Search Results and these settings apply to all pages.

Keywords

KBA , LOD-SF-RMK-CSB , Career Site Builder , Problem

Product

SAP SuccessFactors Recruiting all versions