SAP Knowledge Base Article - Public

2847405 - Webservice Messages are Canceled Automatically by the System

Symptom

Inbound Webservice messages are getting canceled by the system automatically.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Login to Cloud for Customer.
  2. Go to Administrator workcenter.
  3. Open General Settings view.
  4. Click Web Service Message Monitoring view.
  5. Find the relevant message.
  6. Status is Canceled.

Cause

Canceled message has SenderSequenceNumberValue smaller than the previous successful message for the corresponding object.

SenderSequenceNumberValue represents the time-stamp of the IDoc or Webservice message creation in the sender system, so higher the SenderSequenceNumberValue, cloud for customer would treat that as the latest data.

To avoid overwriting of data with outdated record(message), cloud for customer just simply cancels any message being processed having smaller SenderSequenceNumberValue than the previously successful message for that particular object like Sales Order, Business Partners etc.

Resolution

Canceling of messages with smaller SenderSequenceNumberValue is an expected system behavior to avoid overwriting of data with outdated records, such canceled messages can be ignored.

Additionally the successful message can be searched using Advanced Search/Filter in Message Monitoring view with Remote Object ID.

Keywords

SenderSequenceNumberValue, Web Service Message Monitoring, Webservice messages canceled , KBA , LO-INT-COD , CRM On Demand Integration , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-YMT , Integration of C4C with Marketing , AP-RC-WSM , Web Service Message Monitoring View , LOD-CRM-INT-YCM , Integration of C4C with Commerce , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions