SAP Knowledge Base Article - Public

2847830 - SAP Readiness Check 2.0 "Add-On Compatibility" and "Active Business Functions" tiles are empty

Symptom

In SAP Readiness Check 2.0 the sections Add-On Compatability and Active Business Functions are empty

  1. Message "System does not exist in maintenance planner. To add the system to the maintenance planner, check SAP Note 2408911" is shown.
    SNAG-0018.png
  2. Message "No data" is shown. 
    SNAG-0019.png
  3. Message "The data can't be received. Please contact SAP." is shown.
    2021-03-05_14-40-09.png
  4. Message "Technical Error Occurred" is shown.

        ti.png

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP Readiness Check 2.0

Reproducing the Issue

Open SAP Readiness Check and check the Analysis for your System to check Add-On Compatability and Active Business Functions tiles.

Cause

  • System is missing in Maintenance Planner.
  • SID in Maintenance Planner differes from the SAP Readiness Check (SID have to be equal, no long SIDs).
  • Verification is showing Errors in Maintenance Planner.
  • There are no information to report in the readiness check report. 

Resolution

For symptoms #1 & #2 & #4

  1. Ensure that the system is with same SID in the Maintenance Planner and that the System Verification show no errors. If the verify status is red, refer to SAP KBA 2448962 - "Verification Status" shows "ERROR" in Maintenance Planner system list.
    SNAG-0017.png
  2. Click on the system SID then navigate to "Additional Software Details" to check the Active Business Functions maintained. If there are no items maintained here, the readiness check report will show "No data".
    2022-09-23_10-29-39.png
  3. Navigate to "Software" to check the Add-On maintained. Only SAP standard Add-On will be resported in the readiness check report, and no thrid party addons will be reported. Similar to Active Business Functions if there are no information maintained here the readiness check report will show "No data".
  4. If there were changes made, refresh the tiles then the RC report to update the changed information. 
    2021-03-08_10-12-03.png

For symptom #3 & #4

1. Open the system from Maintenance Planner. Make sure the system in verified in a recent date. If you access your system face an error similar to :

Unable to fetch system data for selected system
<SID>[ABAP] Reason: System data is not completely
transferred from SAP Solution Manager

2. Follow the resolution steps of SAP KBA 2323131 - Error in Maintenance Planner:  System data not completely transferred from SAP Solution Manager.

3. After the changes are made, refresh the tiles then the RC report to update the changed information.
2021-03-08_10-12-03.png

4. Please also ensure that you choose the correct customer number when uplodaing the analysis result. Otherwise, it's not able to find the system components info in the Maintenance Planner.

See Also

  • 2408911 - Uploading of System Information into Maintenance Planner

Keywords

Add-On Compatability, Active Business Functions, S4R, ABF, addons, addon, AOC, addon compatibility, "The data can't be received. Please contact SAP.", The add-on check could not be executed due to a technical error. Please create a support incident under component SV-SCS-S4R, "Add-On Compatibility" and "Active Business Functions" are blank , KBA , SV-SCS-S4R , SAP Readiness Check , Problem

Product

SAP Business ByDesign all versions