SAP Knowledge Base Article - Public

2848030 - Error When Posting Goods Receipt in Intercompany Scenario

Symptom

You have an intercompany scenario where both supplier and customer are in the same tenant of ByD. When returning this product using Serial Number YYY, errors are faced when posting goods receipt for Inbound Delivery Notification XXX.

XXX = Inbound Delivery Notification ID

YYY = Serial Number

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Inbound Logistics work center.
  2. Select Inbound Delivery Notifications view.
  3. Search for Inbound Delivery Notification XXX.
  4. Select Inbound Delivery Notification XXX.
  5. Click Post Goods Receipt.
  6. Select Serial Number subtab.
  7. Select Confirm for Serial Number YYY.
  8. You receive the errors:

Action failed

-----> Serial number YYY returned to supplier; cannot be received

Cause

To get the serial number back into the stock, the Owner mentioned in the Registered Product YYY should be same as the Owner mentioned during Post Goods Receipt, under Item Details subtab.

Resolution

To change the Owner of the Registered Product (Serial Number), you can follow the steps:

  1. Go to Service Entitlements work center.
  2. Select Registered Products view.
  3. Search for Registered Product YYY.
  4. Open the registered Product YYY.
  5. Select View All.
  6. Choose Involved Parties tab.
  7. Select the Owner line.
  8. Select Remove.
  9. Click Add Row.
  10. Choose the Owner which shows in Post Goods Receipt screen.
  11. Select Save and Close.

Keywords

Return Supplier Inventory , KBA , AP-IP , Inventory Processing , How To

Product

SAP Business ByDesign all versions