SAP Knowledge Base Article - Public

2848218 - Ticket Interactions Are Displayed Different Depending on the View Type

Symptom

On Ticket Interactions, the content is displayed differently when you look on the List View compaired to the Grid View when dealing with e-mails.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Service work center.
  2. Select the Tickets view.
  3. Open Ticket ID ABC (ABC represents the ID of a Ticket with multiple interactions).
  4. Go to the Interactions facet.
  5. See that the Grid View shows the Interactions with different spacing between lines than the List View.

Cause

In the List View, the whole e-mail content is embedded within an iFrame which ensures that any style tags present in the e-mail HTML header are added, as they are, into the page. Hence, the List View shows the e-mails exactly as they are seen in any other e-mail editor.

For the Grid View, however, it adds the e-mail content directly to the Document Object Model (DOM) and hence any HTML tags in the header, including the stylings, are removed. As there are no margin styles specified, the system framework adds by default a min-height of 16 px, which is the gap you see on the screen.

Resolution

This is the current system behavior.

If there is a need for the e-mails to be shown exaclty as they are, you can use the List View.

Keywords

E-mail ; Ticket ; Ticket Interactions ; Interactions ; List View ; Grid View ; Spacing ; Display ; Incoming Interaction ; , KBA , LOD-CRM-SRP-INT , Ticket Interactions , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions