SAP Knowledge Base Article - Public

2848627 - Matrix Grid Reports Show Users with Incorrect Rating or Appear in the Unrated Section

Symptom

When viewing a matrix grid report, users appear with the incorrect rating or appear in the Unrated section.

Environment

  • SAP SuccessFactors Succession Management
  • SAP SuccessFactors Performance Management
  • SAP SuccessFactors Calibration
  • SAP SuccessFactors People Profile
  • SAP SuccessFactors People Analytics

Cause

  • The latest rating is an “Unrated” rating coming from an in-progress Performance Form
  • The latest rating is an “Unrated” rating coming from an in-progress Calibration Session
  • The latest rating is an “Unrated” rating coming from a completed Performance Form where the user did not populate an Overall Rating
  • The latest rating is an “Unrated” rating coming from a completed Performance Form where the form should not create an Overall Rating (i.e. a Summary section)
  • There are different Rating Scales for the rating (usually 1-5) and the Matrix Grid Reports (usually 1-3) - Expected behavior

Resolution

Review Your Matrix Grid Report Configuration

The process configuration of the Matrix Grid Report determines the rating sources (Live Profile, Performance Management, Calibration) considered in retrieving the latest ratings. Settings to review are:

  1. Navigate to Admin Center > Matrix Grid Reports: Performance-Potential or How vs. What.
  2. Review the following configurations:
    1. What is the Trend Element selected for each axis? The Trend Element selected for each axis will determine the type of ratings you need to look at (Performance, Potential, Objective, Competency, Custom1 or Custom2).
    2. What is the Process selected for each axis? The process selected will determine the source of ratings (People Profile, Performance Forms and/or Calibration Sessions).
      • If you have All data sources selected, all ratings from the instance are included.
      • If another process is selected, navigate to Admin Center > Processes and Forms to understand the configuration (more details explained below).
    3. Is the checkbox “Exclude in-progress forms when retrieving the most recent ratings” enabled? If this checkbox is enabled, the Matrix Grid Report will not consider ratings from in-progress forms, so you don’t need to run the step 2 of this guide - Run the Performance Management report.
    4. Is the checkbox “Use average of all found ratings, instead of latest” enabled? If this checkbox is enabled, you need to retrieve all ratings for the given date range and average them. If this checkbox is disabled (most common), the system will retrieve the latest rating available for the given date range. 

Understanding the selected process

If you have All data sources selected for the Process, the Matrix Grid Report will retrieve ratings from all sources (People Profile, Scorecard, Performance Management, and Calibration). If another option is selected, you’ll need to check the process configuration.

  1. Go to Admin Center > Processes and Forms > select the process selected for the Matrix Grid Report (item b from above screenshot).
  2.  The process configuration is divided into the following sections:
    1. Forms: ratings from the forms included in this section will be considered by the Matrix Grid Report. This means any type of ratings regardless of what is selected in Succession Data.
    2. Succession Data: ratings from the People Profile, Scorecard, and Calibration sessions will be considered by the Matrix Grid Report if the respective Trend element is included in this section.
      • Note: Performance Form Ratings always take precedence over Succession Data regardless of which is last modified.

After analyzing the process, you should understand if data from the People Profile, Scorecard, and Calibration sessions are considered for a given Trend element and what Performance Forms are being considered.

Are in-progress Calibration Sessions included?

If you have Calibration configured in your instance, verify if ratings from in-progress Calibration Sessions are included:

  1. Navigate to Admin Center > Calibration > Manage Calibration Settings > Global Settings.
  2. Verify if “Show In-Progress Calibration Ratings In Live Profile” is enabled:

Run Reports on Each Applicable Domain to Determine the Latest Ratings

Reporting on the ratings from People Profile, Performance Management, and Calibration based on the process configuration of your Matrix Grid Report.

Employee Profile Domain

Run the People Profile report domain since it will display ratings from People Profile, Scorecard, Performance Forms, and completed Calibration Sessions but it will not show Unrated ratings.

NOTE: If the process only includes Performance Forms (i.e. if you are not using “All Data Sources” and the Trend Element is not included under “Succession Data” in the process configuration), skip this step and only run the Performance Management report.

  1. Navigate to Reporting > Report Center > click “New” > select “Report – Table” > click “Select”
  2. Select “Single Domain” and select “Employee Profile” in the domain dropdown > click “Select”
  3. Give a name to the report.
  4. In the “People” tab, click “Refine Criteria” > select “Other Filters” > click “Ok”.
  5. In the “Columns” tab, click “Select Columns” and select the following:
    1. Employee Information – Username
    2. Employee Information – First Name
    3. Employee Information – Last Name
    4. All Ratings Information – Select All
  6. Still in the “Columns” tab, click “Sort Columns” > Add another sorting level > select “Rating End Date”.
  7. In the “Filters” tab, click on “Refine Criteria” and filter based on:
    1. Employee Information - User Sys ID or Username: filter by the user that you are using to troubleshoot the issue.
    2. All Ratings Information – Rating Type: here, you’ll filter by the Trend Elements that you identified in the Matrix Grid Configuration (a. What is the Trend Element selected for each axis?). For example: Performance.
      • NOTE: Filter by one rating type at a time for easier readability.
  8. Save and generate the report.
  9. Identify the latest rating (based on the End Date) that the report shows.
  10. Export the results for reference. Next, you will run Performance Management and Calibration reports, to identify Unrated or in-progress ratings coming from those sources.

Performance Management Domain

If you have Performance Forms included in the process, run this report to identify any Unrated ratings coming from Performance Forms.

  1. Navigate to Reporting > Report Center > click “New” > select “Report – Table” > click “Select”
  2. Select “Single Domain” and select “Performance Management” in the domain dropdown > click “Select”.
  3. Give a name to the report.
  4. In the “People” tab, click “Refine Criteria” > select “Other Filters” > click “Ok”.
  5. In the “Data Sets” tab, select the relevant templates according to the process configured in your Matrix Grid Report. If the process is All data sources, select all templates. If it’s another process, select only the forms included in your process configuration.
  6. In the “Columns” tab, click “Select Columns” and select the columns outlined below. Instead of “Trend”, select the columns related to the Trend Elements configured for your Matrix Grid Report (for example, “Performance”).
    1. Form – Form Template Name
    2. Form – Form Title
    3. Form – Status
    4. Form – Form Start Date
    5. Form – Form End Date
    6. Subject – Username
    7. Subject – First Name
    8. Subject – Last Name
    9. Trend – Overall Trend Rating
    10. Trend – Overall Trend Rating Description
    11. Trend – Overall Trend Rating Scale Min (Competency and Objective only)
    12. Trend – Overall Trend Rating Scale Max (Competency and Objective only)
    13. Trend – Trend Scale Min (Performance and Potential only)
    14. Trend – Trend Scale Max (Performance and Potential only)
  7. Still in the “Columns” tab, click “Sort Columns” > Add another sorting level > select “Form End Date”.
  8. In the “Filters” tab, click on “Refine Criteria” and filter based on:
    1. Subject - User Sys ID or Username: filter by the user that you are using to troubleshoot the issue.
    2. Form – Form Status:
      • If “Exclude in-progress forms when retrieving the most recent ratings” is enabled: filter by “Completed” forms only.
      • If the above setting is disabled: filter by all statuses, except “Deleted”. For example, include “Modify Stage” and “Completed”.
  9. Save and generate the report.
  10. Identify the latest rating (based on the End Date) that the report shows.
  11. Export the results for reference. Next, you will run the Calibration report, to identify Unrated or in-progress ratings coming from Calibration.

Calibration Domain

This report is necessary to understand any Unrated or in-progress ratings coming from Calibration.

NOTE: If the process of your Matrix Grid Report only includes Performance Forms (i.e. if you are not using “All Data Sources” and the Trend Element is not included under “Succession Data” in the process configuration), skip this step and only run the Performance Management report.

  1. Navigate to Reporting > Report Center > click “New” > select “Report – Table” > click “Select”
  2. Select “Single Domain” and select “Calibration” in the domain dropdown > click “Select”.
  3. Give a name to the report.
  4. In the “People” tab, click “Refine Criteria” > select “Other Filters” > click “Ok”.
  5. In the “Columns” tab, click “Select Columns” and select the following:
    1. Cal Session Subject – Subject User Name
    2. Cal Session Subject – Subject First Name
    3. Cal Session Subject – Subject Last Name
    4. Cal Session – Session Name
    5. Cal Session – Session Status
    6. Cal Template – Select All (Template Name, Cycle Start Date and Cycle End Date).
    7. Cal Audit Trail – Audit Data Type
    8. Cal Audit Trail – Old Value
    9. Cal Audit Trail – Old Value Label
    10. Cal Audit Trail – New Value
    11. Cal Audit Trail – New Value Label
  6. Still in the “Columns” tab, click “Sort Columns” > Add another sorting level > select “Cycle End Date”.
  7. In the “Filters” tab, click on “Refine Criteria” and filter based on:
    1. Cal Session Subject - Username: filter by the user that you are using to troubleshoot the issue.
    2. Cal Session – Session Status:
      1. If “Show In-Progress Calibration Ratings In Live Profile” is enabled, filter by all statuses, except “Deleted”. Include “Approved” and “In Progress”.
      2. If the above setting is disabled: filter by status “Approved” only.  
    3. Cal Audit Trail – Audit Data Type: filter by the Trend element that is configured in your Matrix Grid Report configuration. For example, “Performance”.
  8. Save and generate the report.
  9. Identify the latest rating (based on the End Date) that the report shows. The rating to be considered is the “New Value” and “New Value Label”.
    1. Unrated ratings will display as empty values for New Value and New Value label.
    2. Too New To Rate ratings will display as “Too New To Rate”.
    3. Regular ratings will display the rating number (value) and label.
  10. Export the results for reference.

Analyze the results

After running the above reports, compare the ones you ran according to the configured process and configuration to identify the latest rating for the user. Identify the rating with the latest End Date (Rating End Date, Form End Date, Cycle End Date) and this is what is considered by the Matrix Grid Report.

If you have the checkbox Use average of all found ratings, instead of latest enabled, you’ll need to calculate the average of all found ratings (for the date range you are running the report with, always based on the end date of the rating).

How to Correct the Issue
  • The latest rating is an “Unrated” rating coming from an in-progress Performance Form
    • Consider enabling the checkbox Exclude in-progress forms when retrieving the most recent ratings
  • The latest rating is an “Unrated” rating coming from an in-progress Calibration Session
    • Consider disabling the checkbox Show In-Progress Calibration Ratings In Live Profile
  • The latest rating is an “Unrated” rating coming from a completed Performance Form where the user did not populate an Overall Rating
    • The form will need to be corrected or relaunched.
  • The latest rating is an “Unrated” rating coming from a completed Performance Form where the form should not create an Overall Rating (i.e. a Summary section)
    • Remove the form from the Matrix Grid Report process
    • Consider removing the Summary section of the Performance Form so it does not generate Overall Ratings going forward
  • There are different Rating Scales for the rating (usually 1-5) and for the Matrix Grid Reports (usually 1-3)
    • This is expected behavior where the Matrix Grid Report will apply a process called normalization to convert the original rating value to the corresponding value in the Matrix Grid Rating Scale. The normalization process may also be using Custom Weights configured in the Matrix Grid Report.

Keywords

Employee profile domain, adhoc reporting, calibration, trend, succession, inclusive, performance management, audit trail, common issues, unrated, in-progress, live profile, user sys id, , KBA , LOD-SF-SCM-MXG , Matrix Grid Reports (9 Box) , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , LOD-SF-PM-FRM , Forms & Templates , LOD-SF-ANA-RCT-ADH , Ad Hoc & BIRT , LOD-SF-CAL-ADM , Admin Tools, Permissions, Settings , LOD-SF-CAL-EP , Calibrating with Employee Profile , LOD-SF-CAL-PM , Calibrating with Performance Form Data , LOD-SF-EP-TRD , Trend Elements , LOD-SF-PM-CAL , PM-Calibration Issues Specific to PM Forms , LOD-SF-PM-RAT , Ratings and Weights , Problem

Product

SAP SuccessFactors Performance & Goals all versions ; SAP SuccessFactors Succession & Development all versions